【发布时间】:2019-07-13 11:50:37
【问题描述】:
这已经是之前post 中讨论的对象,但是,我不相信答案,因为Google docs 指定可以创建一个设置fs.defaultFS 属性的集群。此外,即使可以以编程方式设置此属性,有时从命令行设置它也更方便。
所以我想知道为什么以下选项在传递给我的集群创建命令时不起作用:--properties core:fs.defaultFS=gs://my-bucket?请注意,我没有包含所有参数,因为我在没有前一个标志的情况下运行了命令,并且它成功创建了集群。但是,当通过这个时,我得到:“失败:无法启动主机:DataNodes 报告数量不足。”
如果有人设法通过设置 fs.defaultFS 来创建一个 dataproc 集群,那该多好?谢谢。
【问题讨论】:
标签: apache-spark hadoop google-cloud-dataproc