【问题标题】:Hadoop on Google Compute Engine谷歌计算引擎上的 Hadoop
【发布时间】:2015-01-07 20:30:53
【问题描述】:

我正在尝试通过“启动点击部署软件”功能在 Google Compute Engine 中设置 hadoop 集群。我创建了 1 个主节点和 1 个从节点,并尝试使用主节点的 start-all.sh 脚本启动集群节点,我收到错误“权限被拒绝(公钥)”。

我已经在从节点和主节点中生成了公钥和私钥。

目前我用我的用户名登录主服务器,是否必须以“hadoop”用户身份登录主服务器。如果是,该用户 ID 的密码是什么。

请告诉我如何解决这个问题。

【问题讨论】:

    标签: hadoop google-compute-engine google-hadoop


    【解决方案1】:

    部署会创建一个用户hadoop,该用户拥有Hadoop 特定的SSH 密钥,该密钥是在部署时动态生成的;这意味着由于 start-all.sh 在后台使用 SSH,您必须执行以下操作:

    sudo su hadoop
    /home/hadoop/hadoop-install/bin/start-all.sh
    

    否则,您的“普通”用户名没有正确设置 SSH 密钥,因此您将无法启动 Hadoop 守护程序,如您所见。

    另外需要注意的是,部署应该已经自动启动了所有 Hadoop 守护程序,因此您不需要手动运行 start-all.sh,除非您在一些手动配置更新后重新启动守护程序。如果部署运行后守护程序没有运行,您可能在初始化期间遇到了一些意外错误。

    【讨论】:

    • 请注意:我的脚本位于/home/hadoop/hadoop-install/sbin/start-all.sh
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2013-12-05
    • 2014-04-18
    • 2016-02-07
    • 2014-04-05
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多