【问题标题】:Capistrano & Symfony: cap aborted! LoadError: cannot load such file -- capifony_symfony2Capistrano 和 Symfony:上限中止! LoadError: 无法加载此类文件 -- capifony_symfony2
【发布时间】:2019-01-30 18:13:12
【问题描述】:

运行部署时出现以下错误:

cap aborted!
LoadError: cannot load such file -- capifony_symfony2
C:/Ruby22/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/Ruby22/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'
C:/xampp/htdocs/surveys6/Capfile:3:in `<top (required)>'
C:/Ruby22/lib/ruby/2.2.0/rake/rake_module.rb:28:in `load'
C:/Ruby22/lib/ruby/2.2.0/rake/rake_module.rb:28:in `load_rakefile'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:689:in `raw_load_rakefile'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:94:in `block in load_rakefile'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:176:in `standard_exception_handling'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:93:in `load_rakefile'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:77:in `block in run'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:176:in `standard_exception_handling'
C:/Ruby22/lib/ruby/2.2.0/rake/application.rb:75:in `run'
C:/Ruby22/lib/ruby/gems/2.2.0/gems/capistrano-3.11.0/lib/capistrano/application.rb:14:in `run'
C:/Ruby22/lib/ruby/gems/2.2.0/gems/capistrano-3.11.0/bin/cap:3:in `<top (required)>'
C:/Ruby22/bin/cap:23:in `load'
C:/Ruby22/bin/cap:23:in `<main>'

我正在使用: Capistrano 版本:3.11.0(Rake 版本:10.4.2) Symfony 2.7.49 版

任何人都可以建议,我觉得它可能与这里的最佳答案有关?..Rails 4, Capistrano 3.0.0, cannot load such file -- deploy

【问题讨论】:

  • 不确定,但我也遇到过 Symfony 和 Cap 的问题,最终改用 Deployer - deployer.org
  • 虽然,我没有在 windows 上使用 capistrano/symphony,但我会尽力提供帮助。可以发Capfile的内容吗?

标签: symfony capistrano capistrano3


【解决方案1】:

可能是调整旧版软件的一个案例。我最终卸载了 Capistrano 3.11 并安装了 Capistrano 2.15.9。这个版本的 Capistrano 可以和我的旧版 Symfony 一起使用。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2012-10-12
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2015-09-14
    • 2016-08-10
    相关资源
    最近更新 更多