【问题标题】:Couldn't Start Mongo DB无法启动 Mongo DB
【发布时间】:2020-08-02 16:30:05
【问题描述】:
● mongod.service - MongoDB 数据库服务器
   已加载:已加载(/lib/systemd/system/mongod.service;已禁用;供应商预设:已启用)
   活动:失败(结果:退出代码)自 IST 周一 2020-04-20 13:32:29 起; 6分钟前
     文档:https://docs.mongodb.org/manual
  进程:27917 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=exited, status=14)
 主 PID:27917(代码=退出,状态=14)

4 月 20 日 13:32:29 manojkumar systemd[1]:启动 MongoDB 数据库服务器。
4 月 20 日 13:32:29 manojkumar systemd[1]:mongod.service:主进程退出,code=exited,status=14/n/a
4 月 20 日 13:32:29 manojkumar systemd[1]:mongod.service:失败,结果为“exit-code”。

【问题讨论】:

  • 好的做法是先检查日志,找出实际原因。这里是日志位置/var/log/mongodb/
  • 你会在这里找到答案on Stackoverflow

标签: mongodb ubuntu


【解决方案1】:

mongodb好像启动失败,一般是mongodb内部文件夹权限不足。

尝试检查/设置:

chown -R mongodb:mongodb /var/lib/mongodb
chown mongodb:mongodb /tmp/mongodb-27017.sock

我找到了讨论here的帖子

【讨论】:

    【解决方案2】:

    对于遇到同样问题安装成功后使用命令(sudo systemctl status mongod)无法启动mongodb的人:

    我必须设置 ulimit -n 64000 才能让它工作。这实际上是在我最初忽略的安装文档here 中提到的。

    【讨论】:

      猜你喜欢
      • 2017-08-02
      • 2012-09-12
      • 2016-06-09
      • 1970-01-01
      • 2014-01-14
      • 1970-01-01
      • 2016-10-31
      • 2017-11-12
      • 1970-01-01
      相关资源
      最近更新 更多