【问题标题】:Visual Studio unable to start debuggingVisual Studio 无法开始调试
【发布时间】:2015-09-12 10:53:30
【问题描述】:

每次我构建解决方案并尝试开始调试时,都会收到以下消息:

无法在 Web 服务器上开始调试。 Web 服务器没有及时响应。这可能是另一个调试器附加到 Web 服务器。

如果我重新启动我的 IIS,我可以开始调试,但如果我再次构建,我必须再次重新启动我的 IIS。我看到几个人有同样的问题,但没有人和我完全一样。

【问题讨论】:

    标签: visual-studio-2010 iis


    【解决方案1】:

    以下链接包含一些有用的答案:

    Unable to start debugging on the web server. Could not start ASP.NET debugging VS 2010, II7, Win 7 x64

    喜欢这个答案:

    1)

    尝试进入 IIS 并检查以确保您正在使用的应用程序池 已启动。很多时候,你会产生一个关闭的错误 应用程序池。你只需要右键单击并开始,你应该是 很好。

    2) 这个答案

    原来罪魁祸首是 IIS Url Rewrite 模块。我有 定义了将调用重定向到 Default.aspx 的规则(设置为 网站的起始页)到网站的根目录,这样我 可以有一个规范的主页 URL。但是,显然VS有问题 对此感到困惑。我的时候没有出现这个问题 使用 Helicon ISAPI_Rewrite 所以我什至没有想到要检查。

    我最终从头开始创建了一个全新的网站并进行了移植 项目/文件一点一点地进入我的解决方案并重建 我的 web.config 直到我发现这个!好吧,至少现在我有一个 使用 .NET 4.0 的网站稍微干净一些(到目前为止,希望我不会运行 进入任何墙壁)--但是多么痛苦!

    【讨论】:

    • 如果有帮助,我已经对应用程序池进行了一些实验。当我将应用程序切换到不同的应用程序池时,我通常可以开始调试,但如果重新构建,我必须重置 IIS 或更改应用程序池
    • 您能否尝试通过以下建议的答案解决问题:stackoverflow.com/questions/15327188/…
    【解决方案2】:

    以管理员模式打开你的 cmd 并运行 cmd

    iisreset
    

    【讨论】:

      猜你喜欢
      • 2017-06-08
      • 1970-01-01
      • 2012-12-28
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多