【问题标题】:How to deploy ASP.Net MVC 5 to IIS 8 Windows Server 2012?如何将 ASP.Net MVC 5 部署到 IIS 8 Windows Server 2012?
【发布时间】:2015-03-12 08:37:53
【问题描述】:

我在 ASP.Net MVC 5 中使用数据库 SQL Server 2012 开发了一个应用程序 现在我想用 IIS 8 在 Windows Server 2012 中部署它

我点击了这个链接:http://www.asp.net/mvc/overview/deployment/visual-studio-web-deployment/deploying-to-iis

但是当我在浏览器中运行我的应用程序时,它给出了错误:

HTTP 错误 500.19 - 内部服务器错误 请求的页面不能 是访问,因为该页面的相关配置数据是 无效。

如果你能详细解释一下,我是这个领域的新手。

【问题讨论】:

  • 请附上您在浏览器中得到的错误描述
  • 此服务器上是否已经安装了任何其他 asp.net 站点,或者这是第一个?

标签: asp.net asp.net-mvc-5 web-deployment iis-8


【解决方案1】:

验证是否在您的服务器中安装了 asp.net 角色。

希望这个链接可以帮助到你:https://technet.microsoft.com/en-us/library/hh831475.aspx

【讨论】:

    【解决方案2】:

    我会确保您安装了最新的 .Net 软件包。我有一个针对 4.5.2 的 MVC5 应用程序会拒绝启动。

    【讨论】:

      【解决方案3】:

      您需要先在 Visual Studio 上选择您的项目来发布它。之后,您需要在 IIS 上创建站点。在某些情况下,您可能会发现映射数据库有困难,因为您需要在数据库服务器上添加权限。

      【讨论】:

        猜你喜欢
        • 1970-01-01
        • 2015-11-11
        • 2013-03-07
        • 2016-05-27
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 2011-12-24
        • 1970-01-01
        相关资源
        最近更新 更多