【发布时间】:2018-08-27 16:36:20
【问题描述】:
我用 alpine、s6 和 samba 构建了一个 docker 容器。 一切看起来都很好,但是当它启动 smbd 时,它会在没有任何日志文件的情况下崩溃。
added interface eth0 ip=172.17.0.6 bcast=172.17.255.255
netmask=255.255.0.0
loaded services
Netbios name list:-
my_netbios_names[0]="ADD372A5C9D7"
INFO: Profiling support unavailable in this build.
Standard input is not a socket, assuming -D option
Becoming a daemon.
exit_daemon: STATUS=daemon failed to start: Failed to create session, error code 1
s6 运行服务:
#!/usr/bin/execlineb -P
smbd --foreground --log-stdout
Dockerfile:
FROM alpine:edge
# env variables
ENV S6_VERSION v1.21.2.1
# install s6-overlay
ADD https://github.com/just-containers/s6-overlay/releases/download/${S6_VERSION}/s6-overlay-amd64.tar.gz /tmp/
RUN tar xzf /tmp/s6-overlay-amd64.tar.gz -C /
RUN apk add --no-cache \
bash shadow \
samba-common-tools \
samba-client \
samba-server \
&& rm -rf /var/cache/apk/*
# add local files
COPY root/ /
EXPOSE 445/tcp
CMD ["/init"]
【问题讨论】: