【问题标题】:Uploading website to webhost, webconfig Runtime error将网站上传到 webhost,webconfig 运行时错误
【发布时间】:2010-11-23 23:42:22
【问题描述】:

我完成了我的网站并将其上传到我的虚拟主机,但在尝试访问该网站时出现此错误(或者在这里查看:clematistest.web.surftown.dk):

运行时错误描述:一个 应用程序错误发生在 服务器。当前的自定义错误 此应用程序的设置阻止 应用程序错误的详细信息 从被远程查看(对于 安全原因)。然而,它可以 由运行在 本地服务器机器。

详细信息:启用此详细信息 要查看的特定错误消息 在远程机器上,请创建一个 标记内 “web.config”配置文件 位于根目录下 当前的网络应用程序。这 然后标签应该有 其“mode”属性设置为“Off”。

注意:您当前所在的错误页面 看见可以被习惯代替 通过修改错误页面 的“defaultRedirect”属性 应用程序的 配置标签指向自定义 错误页面网址。

我尝试放入配置文件,但结果相同。

我应该怎么做才能解决这个问题?

/谢谢

【问题讨论】:

    标签: asp.net


    【解决方案1】:

    如果代码中出现未处理的异常,通常会发生这种情况。

    看看您在配置 web.config 以允许网站远程向您显示错误和堆栈跟踪时遇到问题,

    您可以在您怀疑可能引发异常的部分代码周围添加 TRY 和 CATCH 块...然后在 catch 时,您可以重定向到一个通用的简单错误页面,您可以在其中显示异常的消息。

    编辑:您也可以尝试从全局的 on error 事件重定向到自定义错误页面。

    【讨论】:

    • 听起来是个好主意。等我回家再看看,谢谢。
    【解决方案2】:

    您可以在 windows 事件查看器中查看错误原因(如果它是服务器上的 windows 并且您可以访问它)。或者在你的 web.config 中设置 debug="true" 和 customErrors mode="Off"

    【讨论】:

    • Hmm.. 我尝试输入 debug = "true" 和 customErrors 但它仍然给我同样的错误。 clematistest.web.surftown.dk还有其他建议吗?
    【解决方案3】:

    正如错误消息指出的那样,您可以在解决此问题时完全关闭自定义错误。

    在您的 web.config 中搜索“customErrors” - 如果您有一个相当默认的文件版本,这将被完全注释掉 - 删除 cmets,并将自定义错误模式从“RemoteOnly”更改为“Off” :

    <!-- Web.Config Configuration File -->
    <configuration>
      <system.web>
        <customErrors mode="Off"/>
      </system.web>
    </configuration>
    

    如果没有 customErrors 块,只需在 标记之间添加一个。

    完成后,将其设置回“RemoteOnly”或“On”,并至少添加一个 defaultRedirect 指向您的用户的友好错误消息。

    这将显示完整的错误消息,如果您部署了调试版本(或者您正在运行一个网站并且您已将编译模式设置为调试而不是已编译的 Web 应用程序),您将还可以获取行号等,而不是偏移量。

    一旦您解决了问题,我建议您关注Roberto Sebestyen's advice,并为您的网站添加一些适当的错误处理和报告;)

    【讨论】:

      猜你喜欢
      • 2011-08-09
      • 2020-09-05
      • 1970-01-01
      • 1970-01-01
      • 2017-11-16
      • 1970-01-01
      • 2017-08-13
      • 2019-09-04
      • 1970-01-01
      相关资源
      最近更新 更多