【发布时间】:2021-08-08 06:16:10
【问题描述】:
目前我在 Prometheus 的 kubernetes-nodes 工作中,端点 /api/v1/nodes/gk3-<cluster name>-default-pool-<something arbitrary>/proxy/metrics 正在被抓取
但问题是当我在邮递员上手动尝试时,我收到了一个 403 错误,上面写着 GKEAutopilot authz: cluster scoped resource "nodes/proxy" is managed and access is denied
如何在 GKE Autopilot 上解决这个问题?
【问题讨论】:
-
您需要使用有权访问该子资源的有效 ServiceAccount 令牌。
-
@coderanger 我已经有一个 prometheus 的服务帐户,允许在 prometheus 上使用完整的令牌访问
nodes/proxy,这个问题似乎与 GKE 的自动驾驶有关
标签: kubernetes google-kubernetes-engine prometheus