【发布时间】:2019-04-12 11:12:08
【问题描述】:
我想在 Azure 云服务工作者角色中托管一个嵌入式 FTP 服务器。
为了提供对 FTP 服务器的被动访问,它使用端口范围 20000-21000。
在ServiceDefinition.csdef 中,我定义了所有需要的端口(见截图)。
主要问题是大量的端口。如果我尝试将服务上传到云中,我会收到以下错误。
验证错误:输入端点的数量无效 - 当前为 1002, 最大限度。 25
如何使用云服务完成这项工作?
【问题讨论】:
-
这个 repo 的自述文件说 PASV 模式不起作用。也许是因为WorkerRole only supports 25 ports。您可以创建一个 VM 可用的一组 IIS FTP 服务器并安装共享存储。
-
是的,我们的产品现在正在做。但我们明确希望通过自定义嵌入式 FTP 服务切换到工作角色。我知道 FTP2Azure,但他们甚至没有实现被动连接。所以很抱歉,但这对我的问题没有帮助。
标签: c# azure endpoint azure-cloud-services ftp-server