【问题标题】:Github self-hosted runner fails to run as a service on RH LinuxGithub 自托管运行器无法在 RH Linux 上作为服务运行
【发布时间】:2023-02-17 19:14:24
【问题描述】:

我在 RH Linux EC2 实例上安装了 GitHub 自托管运行器。它在交互模式下运行良好:./run.sh

但是当尝试将其作为服务运行时。 (sudo ./svc.sh start),启动失败。

主动:失败 runsvc.sh (code=exited, status=203/EXEC)

关于如何解决这个问题的任何想法?

【问题讨论】:

    标签: github-actions-self-hosted-runners


    【解决方案1】:

    我在 Oracle 云上运行一个 Oracle Linux 8 实例,遇到了同样的问题,输出的错误完全一样。您很可能正在运行 SELinux。这会阻止您的服务启动。这个命令帮助我解决了这个问题:

    chcon system_u:object_r:usr_t:s0 runsvc.sh
    

    【讨论】:

    • 您的答案可以通过其他支持信息得到改进。请edit 添加更多详细信息,例如引用或文档,以便其他人可以确认您的答案是正确的。你可以找到更多关于如何写出好的答案的信息in the help center。
    • 你的意思是运行上面之后,我们就可以重启systemctl服务来恢复了吗?
    【解决方案2】:

    运行 chcon 命令后,我可以运行 start 但它立即崩溃并显示 status=1/failure。 所以我在 run.sh 命令上运行了 chcon 命令,在 systemd 中找到的服务文件中,我输入了 run.sh 而不是 svc.sh start。

    现在它开始没有问题,我可以得到服务的状态。

    Active: active (running) since Fri 2023-02-10 11:59:14 CET; 6s ago
    Main PID: 2065992 (run.sh)
    

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 2021-02-04
      • 2017-10-20
      • 1970-01-01
      • 2020-01-06
      • 2023-03-27
      • 2020-03-09
      • 2022-08-13
      相关资源
      最近更新 更多