【发布时间】:2022-11-02 19:14:15
【问题描述】:
我在我的测试集群中安装了 cilium(AWS,删除了 AWS CNI,因为我们使用了 cilium CNI 插件),每当我删除 cilium 命名空间(或运行helm delete)时,hubble-ui pod 就会陷入终止状态。该 pod 有几个容器,但我注意到一个名为 backend 的容器在命名空间被删除时以代码 137 退出,从而使 hubble-ui pod 和 pod 所在的命名空间停留在Terminating 状态。从我在线阅读的内容来看,当容器尝试使用已分配的更多内存时,它们会以 137 退出。在我的测试集群中,没有在 pod 或命名空间上定义资源限制 (spec.containers.[*].resources = {})。没有显示错误消息作为错误原因。我使用的是cilium helm包v1.12.3,但是这个问题甚至在我们更新helm包版本之前就已经存在了。
我想知道是什么导致了这个问题,因为它破坏了我的 CI 管道。 如何确保后端容器正常退出? (与清除终结器相反)。
【问题讨论】:
标签: kubernetes amazon-eks kubernetes-pod cilium