【问题标题】:IBM WebSphere Application server SOAP connector issueIBM WebSphere 应用程序服务器 SOAP 连接器问题
【发布时间】:2022-10-21 18:18:10
【问题描述】:

谁能帮我解决以下问题,我们正在使用 SOAP 连接器端口 8884 连接到 WebSphere 应用程序服务器,每天我们都会重新启动服务器, 但是我们重启服务器后随机出现以下错误,然后它会在第二天服务器重启后开始工作

com.ibm.websphere.management.exception.ConnectorException: ADMC0016E: 系统无法创建 SOAP 连接器以连接到端口 8884 上的主机 MYDP01。 在 com.ibm.websphere.management.AdminClientFactory.createAdminClientPrivileged(AdminClientFactory.java:635) 在 com.ibm.websphere.management.AdminClientFactory.access$000(AdminClientFactory.java:127) 在 com.ibm.websphere.management.AdminClientFactory$1.run(AdminClientFactory.java:210) 在 com.ibm.ws.security.util.AccessController.doPrivileged(AccessController.java:63) 在 com.ibm.websphere.management.AdminClientFactory.createAdminClient(AdminClientFactory.java:206) 在 com.myapp.websphere.MyAppWebSphereThread.run(MyAppWebSphereThread.java:77) 引起:java.lang.reflect.InvocationTargetException 在 sun.reflect.GeneratedConstructorAccessor75.newInstance(未知来源) 在 sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:57) 在 java.lang.reflect.Constructor.newInstance(Constructor.java:437) 在 com.ibm.websphere.management.AdminClientFactory.createAdminClientPrivileged(AdminClientFactory.java:457) ... 5 更多 引起:com.ibm.websphere.management.exception.ConnectorNotAvailableException: [SOAPException: faultCode=SOAP-ENV:Client; msg =打开套接字时出错:java.io.IOException:sslSocket.startHandshake 期间出现异常:PKIX 路径构建失败:com.ibm.security.cert.IBMCertPathBuilderException:无法找到请求目标的有效证书路径; targetException=java.lang.IllegalArgumentException:打开套接字时出错:java.io.IOException:sslSocket.startHandshake 期间出现异常:PKIX 路径构建失败:com.ibm.security.cert.IBMCertPathBuilderException:无法找到请求目标的有效证书路径] 在 com.ibm.ws.management.connector.soap.SOAPConnectorClient.reconnect(SOAPConnectorClient.java:437) 在 com.ibm.ws.management.connector.soap.SOAPConnectorClient.(SOAPConnectorClient.java:236) ... 9 更多 原因:[SOAPException: faultCode=SOAP-ENV:Client; msg =打开套接字时出错:java.io.IOException:sslSocket.startHandshake 期间出现异常:PKIX 路径构建失败:com.ibm.security.cert.IBMCertPathBuilderException:无法找到请求目标的有效证书路径; targetException=java.lang.IllegalArgumentException:打开套接字时出错:java.io.IOException:sslSocket.startHandshake 期间出现异常:PKIX 路径构建失败:com.ibm.security.cert.IBMCertPathBuilderException:无法找到请求目标的有效证书路径] 在 org.apache.soap.transport.http.SOAPHTTPConnection.send(SOAPHTTPConnection.java:475) 在 org.apache.soap.rpc.Call.WASinvoke(Call.java:510) 在 com.ibm.ws.management.connector.soap.SOAPConnectorClient$4.run(SOAPConnectorClient.java:395) 在 com.ibm.ws.security.util.AccessController.doPrivileged(AccessController.java:118) 在 com.ibm.ws.management.connector.soap.SOAPConnectorClient.reconnect(SOAPConnectorClient.java:380) ... 10 更多

【问题讨论】:

    标签: soap websphere soap-client pkix


    【解决方案1】:

    我刚刚检查过, 请按照说明执行以下下一步:

    1. 在 Web Admin Console 中检查和编辑

      应用程序服务器 查看有关此页面的更多信息 展开或折叠 应用程序服务器 > Server1TPEXSrv01 > 端口 >SOAP_CONNECTOR_ADDRESS指定此服务器用于连接的 TCP/IP 端口。

      配置
      所需信息 主机 uat-tpx02 所需信息 港口

    2. 在服务器文件中

      您在下面作为该行并检查并编辑 SOAP 连接器地址

      /uat2app/TPEXSrv10/config/cells/server1Cell10/nodes/server1TPEXNode10/serverindex.xml

      谢谢并恭祝安康 tandn

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2011-11-30
      • 1970-01-01
      • 2014-03-10
      • 2021-06-29
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多