【问题标题】:EDB lasso failing to connect to postgres server on debianEDB 套索无法连接到 debian 上的 postgres 服务器
【发布时间】:2022-09-24 11:31:38
【问题描述】:

我输入的任何命令似乎都不起作用。我不断收到以下输出:

./lasso-linux-x86_64 -p 5434 2022-09-23T09:48:29+0100 信息 EDB 套索 4.3.0 PostgreSQL 连接错误 在套接字 \"/var/run/postgresql/.s.PGSQL.5434\" 上连接到服务器失败:没有这样的文件或目录 服务器是否在本地运行并接受该套接字上的连接?

我怎样才能减轻这种情况?

标签: postgresql edb


【解决方案1】:

您可以使用以下格式执行套索报告尝试连接在 postgres 集群上运行的任何数据库,这将执行此命令。

./lasso-linux-x86_64 -H /tmp -p 5444 <DBNAME>

注意:如果 /tmp 中不存在套接字,您可以使用 SHOW unix_socket_directories 报告的任何套接字以及主机参数 -H 的 localhost 进行连接。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2012-11-04
    • 1970-01-01
    • 2017-03-24
    • 2015-06-20
    • 2018-03-09
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多