【问题标题】:Ruby rails error: Bundler could not find compatible versions for gem "bundler":Ruby rails 错误:Bundler 找不到 gem \"bundler\" 的兼容版本:
【发布时间】:2022-08-14 00:46:19
【问题描述】:

Bundler 找不到 gem \"bundle\" 的兼容版本:

错误如下

Bundler could not find compatible versions for gem \"bundler\":
  In Gemfile:
    bundler (~> 2.2)

    rails (= 6.1.4.6) was resolved to 6.1.4.6, which depends on
      bundler (>= 2.2.0)

  Current Bundler version:
    bundler (2.1.4)
This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?

Could not find gem \'bundler (~> 2.2)\', which is required by gem \'rails (= 6.1.4.6)\', in any of the relevant sources:
  the local ruby installation

    标签: ruby-on-rails ruby rubygems bundler


    【解决方案1】:

    您的解决方案实际上在您收到的错误消息中。跑

    gem install bundler
    

    安装最新版本的捆绑器(应该满足约束

    您还可以通过指定版本标志来指定任何 gem 的特定版本。例如。

    gem install bundler -v 2.2.0
    

    【讨论】:

    • 我已经这样做了,但我仍然得到同样的错误。
    【解决方案2】:

    gem install bundler --version 2.2.19 --default

    【讨论】:

      猜你喜欢
      • 2023-03-14
      • 2022-11-10
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2011-10-31
      • 1970-01-01
      • 2017-07-17
      • 2018-02-09
      相关资源
      最近更新 更多