【发布时间】:2022-07-30 03:20:11
【问题描述】:
使用 FinkUI 上传 Flink 任务 Jar 时,任务启动失败,我重新上传 Flink 任务 Jar。这时候JVM Metaspace就会异常增加。是什么原因?
【问题讨论】:
标签: apache-flink
使用 FinkUI 上传 Flink 任务 Jar 时,任务启动失败,我重新上传 Flink 任务 Jar。这时候JVM Metaspace就会异常增加。是什么原因?
【问题讨论】:
标签: apache-flink
即使我也面临同样的问题。我有一个分配了 512 MB 作业管理器 JVM 元空间的 flink 集群。每当我运行批处理管道 3 到 4 次时,它都会完全填满元空间,然后在我重新启动作业管理器之前它不会加载任何新的批处理作业。
【讨论】: