【问题标题】:Redshift copy command failureRedshift 复制命令失败
【发布时间】:2018-04-18 13:00:27
【问题描述】:

我正在使用 Amazon Redshift COPY 命令将新行插入到表中。

复制命令失败并出现错误消息:

index "pg_toast_16408_index" is not a btree

我注意到问题的发生是因为description 字段包含长字符串。当我尝试在没有此字段的情况下进行复制时,它可以工作!

有人知道这是为什么吗?我该如何克服这个问题?

【问题讨论】:

  • 您的复制命令到底是什么(删除密码等)?目标栏“描述”有多长? varchar(最大值)?你在目标表上有什么“限制”?请分享您的目标表的 ddl。 (请您使用此信息更新您的问题吗?)

标签: amazon-web-services amazon-redshift


【解决方案1】:

使用TRUNCATECOLUMNS参数:

将列中的数据截断为适当的字符数,使其符合列规范。仅适用于具有 VARCHAR 或 CHAR 数据类型的列,以及大小不超过 4 MB 的行。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2014-09-11
    • 1970-01-01
    • 2019-02-16
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多