【发布时间】:2018-04-18 13:00:27
【问题描述】:
我正在使用 Amazon Redshift COPY 命令将新行插入到表中。
复制命令失败并出现错误消息:
index "pg_toast_16408_index" is not a btree
我注意到问题的发生是因为description 字段包含长字符串。当我尝试在没有此字段的情况下进行复制时,它可以工作!
有人知道这是为什么吗?我该如何克服这个问题?
【问题讨论】:
-
您的复制命令到底是什么(删除密码等)?目标栏“描述”有多长? varchar(最大值)?你在目标表上有什么“限制”?请分享您的目标表的 ddl。 (请您使用此信息更新您的问题吗?)
标签: amazon-web-services amazon-redshift