【发布时间】:2020-03-10 01:42:13
【问题描述】:
实际上,当我在 GCP 中创建一台新机器时,谷歌计算引擎正在为我分配一个 IP 1xx。 只有我有大约 30 台机器,但是,当 kubernetes 生成一个新节点时,IP 会增加。 如何重置此 IP 池?
例如,现在我正在尝试生成市场部署 (rabbitmq),但无法保留内部 IP。
【问题讨论】:
标签: google-cloud-platform ip google-compute-engine
实际上,当我在 GCP 中创建一台新机器时,谷歌计算引擎正在为我分配一个 IP 1xx。 只有我有大约 30 台机器,但是,当 kubernetes 生成一个新节点时,IP 会增加。 如何重置此 IP 池?
例如,现在我正在尝试生成市场部署 (rabbitmq),但无法保留内部 IP。
【问题讨论】:
标签: google-cloud-platform ip google-compute-engine
TL;DR:CGE Instances 支持两种类型的内部 IP 地址:静态内部和临时。在这两种情况下,IP 都会一直连接到资源,直到它们明确地与资源分离。所以如果你不能保留更多的IP地址是因为你的IP地址用完了。
Google 发布了一份名为 IP addresses 的文档,其中解释了如何将 IP 地址分配给 GCP 中的资源。
根据您的问题,您似乎拥有custom VPC。你得到的错误是因为你的 IP 地址用完了。
删除资源时会释放临时 IP 地址。但是当资源被删除时,静态内部地址不会自动删除,它只会被分离。很可能您有很多未附加到资源的保留地址。
最后,Stackoverflow 可能不是这个问题的最佳论坛。我强烈建议您在Serverfault 中分享您的问题,因为这是一个更好的基础架构问题论坛。
【讨论】: